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This exercise is intended only as an educational tool to assist those who wish to learn how to use ANSYS. It is not
intended to be used as a guide for determining suitable modeling methods for any application. The author assumes
no responsibility for the use of any of the information in this tutorial. There has been no formal quality control
process applied to this tutorial, so there is certainly no guarantee that there are not mistakes on the following pages.
The author would appreciate feedback at the email address above if mistakes are discovered in this tutorial.

In this exercise, you will solve the 2-D heat conduction problem below, using ANSYS. The
problem is adapted from the textbook, Introduction to Heat Transfer, by Frank Incropera and
David P. Dewitt. You will solve for the temperature distribution within the rectangular plate,
based on the specified temperatures on the plate edges, and the plate dimensions. Step-by-step
instructions are provided beginning on the following page.

Note: Thermal conductivity of the plate, KXX=401 W/(m-K)
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The steps that will be followed, after launching ANSYS, are:
Preprocessing:
1. Change Jobname.
2. Define element type. (Plane55 element, which is a 2-D, 4-node element for thermal analysis.)
3. Define material properties. (Thermal Conductivity -- only property required for this analysis.)
4. Create the rectangular area.
5. Specify mesh density controls. (We will specify numbers of element divisions along lines.)
6. Mesh the area to create nodes and elements.
Solution:
7. Specify temperatures along lines that define the edges of the plate.
8. Solve.
Postprocessing:
9. Plot the temperature distribution.
10. Select nodes along the plate center (x=5 in.).
11. List locations of these center nodes by node number.
12. List the temperatures at each of these nodes.
Re-analysis
13. Modify Mesh / Re-analyze. (Primarily repeating earlier steps.).
Exit
14. Exit the ANSYS program, saving all data.
_____________________________________________________________________________

Notes:
•

It is assumed in this tutorial that the user has already launched ANSYS and is working in
the Graphical User Interface (GUI).

•

The menu picks needed to perform all required tasks are specified in italics in the stepby-step instructions below. It is sometimes more convenient to enter certain commands
directly at the command line. The method of direct command line entry, however, is not
covered in this exercise. Primarily, in this exercise, the analysis will be performed using
menu picks from the ANSYS Graphical User Interface. Often, as an alternative, an input
file, known as a “batch file”, is created, which is simply an ASCII text file containing a
string of ANSYS commands in the appropriate order. ANSYS can read in this file as if it
were a program, and perform the analysis in “batch mode”, without ever opening up the
Graphical User Interface. The batch file option is not covered in this exercise.

SUGGESTION: As you work through this exercise, on the ANSYS Toolbar click on
“SAVE_DB” often!

At any point, if you want to resume from the previous time the model was saved, simply click on
“RESUM_DB” on this same Toolbar. Any information entered since the last save will be lost,
but this is a nice feature in the event that you make an input mistake, and are unsure of how to
correct it.
There are a number of ways to model a system and perform an analysis in ANSYS. The steps
below present only one method.

Preprocessing:
1. Change jobname. On the Utility Menu across the very top of the screen, select:
File -> Change Jobname
Enter “platetmp”, and click on “OK”.

2. Define element type: Preprocessor -> Element Type -> Add/Edit/Delete
Click on “Add”. The “Library of Element Types” menu appears, as shown. Scroll down
to highlight “Thermal Solid”, and “Quad 4node 55” as shown. Click on “OK”, then
“Close”. Note that in ANSYS, this element is sometimes referred to as “Plane55”,
because it is a 2-D planar element, and it is element type 55 in the ANSYS element
library.

3. Define Material Properties: Preprocessor -> Material Properties -> Material Models

A dialogue box appears:

In the dialogue box that appears, on the right hand side, choose:

Thermal -> Conductivity -> Isotropic

Another box appears. Enter “401” for KXX (thermal conductivity), then click on “OK”.
KXX is the only material property needed for this analysis.

Close the other box (the one headed “Define Material Model Behavior”) by clicking on the red
“X” in the upper right-hand corner.

4. Create a rectangular area:
Preprocessor -> Modeling-> Create -> Areas -> Rectangle -> By Dimensions
Fill in the fields as shown, then click “OK”.

5. Specify mesh density controls.
We will specify numbers of element divisions along lines. Choose:
Preprocessor -> -Meshing- Size Cntrls -> Manual Size -> Lines-> Picked Lines
The picking menu (below left) appears. On the graphics window, click on the bottom
horizontal line (this is one of the 10 meter lines), to highlight it. Then, click “OK” in the
picking menu. Then, the “Element Size” menu (below right) appears. Enter “6” for
“NDIV”, as shown, then click “OK”.

Now, repeat the above process to specify 12 divisions along either of the vertical lines. It
is not necessary to specify a value for all four lines, you just need a value for one of the
horizontal lines and one of the vertical lines. However, if you do specify a value for all
four lines, make sure you use the same number of divisions for both horizontal lines, and
the same number of divisions for both vertical lines. Of course, as specified above, the
vertical and horizontal lines do not need to have the same value. It is a problem,
however, if you specify different values for parallel lines on opposite ends of the plate.

6. Mesh the rectangle to create nodes and elements.
Preprocessor -> Meshing -> Mesh -> Areas -> Mapped -> 3 or 4 Sided
A picking menu appears. Select “Pick All”. The rectangle will be meshed. You will see
a number of small rectangles drawn on the larger rectangular area. Each small rectangle
is a “finite element”. There are four nodes associated with each individual element. The
nodes are at the corners of the elements.

Solution:
7. Apply temperatures around the edges:
Solution -> Define Loads-> Apply -> Thermal-> Temperature -> On Lines
A picking menu appears. Highlight the two vertical lines (the 20 meter lines), which
have a temperature of 100 C, then click on “OK” in the picking menu. The box on the
next page appears. Highlight “TEMP” for “DOFs to be constrained”, and enter “100” for
“VALUE”, as shown.

Repeat the above process to apply the 100 C temperature to the bottom horizontal line,
but in this case, choose “Yes” for “Apply TEMP to endpoints?”. Repeat the process
once more, to apply the 200 C temperature to the top horizontal line, but in this case,
choose “No” for “Apply TEMP to endpoints?”.
Now, to address the fact that two corners do not have a specified temperature, as an
approximation, we will set the temperature at these to corners to 150 C.
Solution -> Define Loads-> Apply -> Thermal-> Temperature -> On Keypoints
A picking menu appears. Note that there are four “keypoints” in the model, one at each
corner of the large rectangular area. Click on the upper two corners, at the intersections
of the 100 C and 200 C lines. When these corner “keypoints” are highlighted, choose
“OK” in the picking menu, and the following box appears:

Click on “TEMP” for “DOFs to be constrained” and enter “150” for VALUE, then click
“OK”.
Note: In some cases, when you want to repeat the same process two or more times, you
can click “Apply” in the box, instead of “OK”. That issues the command, but leaves the
box open. Clicking “OK” issues the command, but leaves the box open. Sometimes,
though, using the “Apply” option can cause problems, if you are not careful. You might
click on “Apply” to issue the command, then immediately click on “OK” to close the
box, and this issues the command twice. Sometimes, that is not a problem, and
sometimes it is. So, in this exercise, you are just asked to click on “OK” in each case,
then repeat the entire procedure. For the relatively simple modeling effort undertaken in
this exercise, this approach does not add much work, and is probably less likely to result
in errors.

8. Solve the problem: Solution ->-Solve -> Current LS
Click “OK” in the “Solve Current Load Step” Box. Soon after clicking “OK”, you
should see a note in a box saying “Solution is done!” You may close this box.
Postprocessing:
9. Plot the temperature distribution:
General Postproc -> Plot Results -> Contour Plot-> Nodal Solu
The box below appears. Click on “DOF solution”, then “Temperature”, then click “OK”.
In the graphics window, a plot, as shown on the following page, should appear.

Temperature Distribution Color Contour Plot:
Note that the temperature values
corresponding to the colors are shown in the legend at the bottom of the plot.

10. Select nodes along the plate center (x=5 meters).
For comparison with the analytical solution, you will need a listing of specific
temperatures at specific locations in the plate. ANSYS has calculated a temperature at
each “node”. Because of our method of creating the model by automatic “meshing” of
the rectangle, at this time, we do not know specific node numbers at specific locations.
But, we can get a listing of node numbers, including the locations of each node, and also
a listing of temperatures by node numbers. To keep the amount of information to a
workable level, it is probably best to include in these lists only a subset of nodes. To get
such a list, we can first select only the nodes at x=5 meters. This is a case where it is
probably easiest to just use the direct command line entry option, rather than operate
through the menus. On the command line, type “nsel,s,loc,x,5”, as shown below, and hit
enter:

11. List the locations of the selected nodes.
On the top “Utility Menu”:

Choose List -> Nodes. In the box that appears, just click on “OK” at the bottom. A
listing box appears:

You can get a hard copy of the information in this box by clicking, in this box (see
above): File -> Print. You can save this information to a file using the option, File ->
Save As.

12. List the temperatures at each of these nodes.
General Postproc -> List Results -> Nodal Solution
In the box that appears, click on “DOF Solution” and “Temperature”, as shown, then
click “OK”.

A listing, as shown on the following page, should appear. The locations of the same
nodes have already been listed, in Step 11 above, so the results for these nodes can be
checked with the analytical solution.

Re-select all nodes in the model for additional plotting, or listing, as desired. To do this,
simply type, at the command line: “allsel”, then hit enter:
Subsequent lists and plots will include all nodes. Steps 10, 11, and 12 could be repeated
to get listings of temperatures of nodes at other locations.

13. Modify Mesh / Re-analyze
The general idea in finite element modeling is that the finer the mesh (i.e. the more nodes
and elements used), the more accurate the solution. There is a cost associated with using
a large model, however. The solution time, the computer memory requirements, and the
computer hard drive space needed increase as the mesh density is increased. For this
particular analysis, however, unless an extremely fine mesh is used, the solution will
probably be completed very quickly, and the available memory and hard drive space
should be sufficient. This same problem can be re-solved, with a finer mesh, without
starting back at the beginning of these instructions. To do this, follow the steps below:
13a) Clear the existing nodes and elements:
Preprocessor -> Meshing-> Clear -> Areas

A picking menu appears. Select “Pick All”. The rectangular area still exists. You have
only deleted the nodes and elements. To see the rectangular area in the graphics window,
you may need to click on “Plot” on the top “Utility Menu”, then, choose “Areas”. The
rectangle should appear.
13b) Clear the previously specified mesh controls:
Preprocessor -> -Meshing- Size Controls -> -Lines- Clr Size
A picking menu appears. Select “Pick All”.
13c) Specify new mesh controls. Repeat step 5 from the initial analysis. Except, in this
case, use larger values for number of element divisions (NDIV). In step 5 previously, the
number of element divisions chosen along the bottom horizontal line was 6, and the
number of element divisions chosen along a vertical line was 12. This time, increase
these numbers. However, if you want to compare your results with the analytical solution
along the x=5 meter location, you will need to make sure you use an even number of
divisions along the horizontal line. That way, when you select nodes at x=5, there will
be nodes along that center line.
13d) Remesh the model. Repeat step 6 from the initial analysis. To plot the elements,
you may need to type, at the command line: eplot
13e) Re-solve. Repeat step 8 from the initial analysis. You do not need to repeat step 7
from the initial analysis. Specified temperatures were applied to lines, instead of directly
to nodes. So, even though we re-meshed, the temperature boundary conditions still exist,
because we never modified the lines that define the large rectangle.
13d) Post-process to obtain results for the finer mesh. Repeat steps 9-12 from the
previous analysis. For a finer mesh, you should see smoother curves on the temperature
contour plot, and the calculated temperatures should be in better agreement with the
analytical solution.

14. Exit ANSYS, Saving All Data. On the ANSYS Toolbar, choose:
Quit ->Save Everything -> OK
To recall the model and solution at a later date, assuming you have deleted no files,
simply re-launch ANSYS, specify the same working directory as before, re-issue the
same jobname as used in Step 1 of these instructions, and then click on “RESUME_DB”
on the ANSYS Toolbar shown above. To see the resumed model in the graphics
window, you may then need to click on “Plot” on the top “Utility Menu”. Then, choose
either “Elements”, “Nodes”, or “Areas”, depending on which entities you wish to plot.

